Posted on 21-07-2009
Filed Under (技术) by waterlin

WOZ模块给Zen-cart提供了集成WordPress作为其博客系统的机会,不过,如果你用的是WordPress2.7版本,集成完毕后访问首页(http://your.zen-cart.com/index.php?main_page=wordpress),可能会出现类似下面的错误:

Warning: Cannot modify header information – headers already sent by (output started at E:\xampp\htdocs\zen-cart-with-wordpress\includes\templates\template_default\common\html_header.php:22) in E:\xampp\htdocs\zen-cart-with-wordpress\wordpress2.7.1\wp-includes\pluggable.php on line 850

而WordPress2.5版本则不会有类似的问题。

要解决这个问题很容易,只要把WordPress网址转发功能给屏蔽掉就好了。在WordPress主题的functions.php文件里加上这么一行代码就好了:

remove_filter(‘template_redirect’,’redirect_canonical’);

如果你用的是WOZ,则在default主题的functions.php文件里加入这段代码即可。有关这个问题的详细解释,以及WordPress转发网址的理由,可以查看Velvet Blues的这篇文章

© 2009, 浏忙大爆炸. All rights reserved.
除非注明,浏忙大爆炸文章均为原创,转载请以链接形式标明本文地址。

(0) Comments    (881) Views    Read More   
Post a Comment
Name:
Email:
Website:
Comments: